Uploaded image for project: 'Node Driver'
  1. Node Driver
  2. NODE-92

Collection class is not invoking its "super" methods

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker - P1
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Environment:
      macbook pro retina; osx maveriks; 16gb RAM
    • Operating System:
      ALL
    • # Replies:
      1
    • Last comment by Customer:
      true

      Description

      node-mongodb-native/lib/mongodb/collection.js

      i've been using 1.3.19 and when I updated to 1.3.20 I noticed that none of my scripts were working.

      on inspecting/stepping through the code, I noticed that the functionality previously in lib/mongodb/collection.js has been abstracted out.

      most of the Collection methods look like this:

      Collection.prototype.findAndModify = function() { return core.findAndModify; };

      when — I assume — they should look, something like this:

      Collection.prototype.findAndModify = function() { return core.findAndModify.apply( this, arguments ); };

      as the Collection methods simply return a function, nothing is actually happening and as such a program will just hang without throwing any errors.

      i marked this as a blocker as it causes any node program node-mongodb-native to stop working, apologies if this is no considered a blocker.

        Activity

        • Comments
        brandon.zacharie Brandon Zacharie added a comment -

        I had this same issue today. I was originally using the Node.js (0.10.22) mongodb driver 1.3.20 installed via NPM (1.3.15). I rolled back to 1.3.19 (`npm uninstall mongodb` ... `npm install mongodb@1.3.19`) upon reading this report and everything worked again. I rolled forward (`npm update`) to see if I could reproduce the problem and I couldn't. I'm not sure what that means but I would put NPM on the suspects list.


          People

          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since reply:
              1 year, 39 weeks, 5 days ago
              Date of 1st Reply: