Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major - P3 Major - P3
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: 1.3.0RC1
    • Component/s: None
    • Labels:
      None
    • Operating System:
      ALL
    • # Replies:
      3
    • Last comment by Customer:
      false

      Description

      There is a strange behavior when overriding the batchInsert method. It has been introduced in the 1.2.7 version.

      You can see more details and how to reproduce it here: https://github.com/mandango/mandango/issues/17#issuecomment-5195810

        Activity

        Hannes Magnusson
        added a comment -

        In the current 1.2.x series we do not type hint on array, as that would be backwards compatibility break.

        In the upcoming 1.3 series this will change, and both arguments will be typehinted as arrays.

        Show
        Hannes Magnusson
        added a comment - In the current 1.2.x series we do not type hint on array, as that would be backwards compatibility break. In the upcoming 1.3 series this will change, and both arguments will be typehinted as arrays.
        John Wards
        added a comment -

        This is still an issue in 1.3.0beta2

        Show
        John Wards
        added a comment - This is still an issue in 1.3.0beta2
        Hannes Magnusson
        added a comment -

        In 1.3.0beta2 both arguments are typehinted.
        If the class extending MongoCollection does not do the same you will get the error.

        Note: We have introduced several typehints in the 1.3 series, so chances are that several classes will issue similar error messages

        This change was required to provide meaningful reflection information, make things more obvious to the user which types are expected - and to be consistent with the documented behaviour.

        We are sorry for not having done this from the getgo and needing to break backwards compatibility at this time

        Show
        Hannes Magnusson
        added a comment - In 1.3.0beta2 both arguments are typehinted. If the class extending MongoCollection does not do the same you will get the error. Note: We have introduced several typehints in the 1.3 series, so chances are that several classes will issue similar error messages This change was required to provide meaningful reflection information, make things more obvious to the user which types are expected - and to be consistent with the documented behaviour. We are sorry for not having done this from the getgo and needing to break backwards compatibility at this time

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since reply:
              1 year, 30 weeks, 2 days ago
              Date of 1st Reply: