Uploaded image for project: 'Compass '
  1. Compass
  2. COMPASS-4823

Investigate changes in SERVER-55596: Exclude "isMaster" command from API Version 1

    XMLWordPrintable

    Details

    • Type: Investigation
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: No version
    • Component/s: None
    • Labels:
      None
    • Documentation Changes:
      Not Needed

      Description

      Downstream Change Summary

      "isMaster" is no longer in API Version 1, so you can't call it with apiStrict. MongoClients configured with apiStrict won't be able to connect until DRIVERS-1633. After that they'll call "hello" instead of "isMaster" if they're configured with API parameters. I've updated the legacy mongo shell so it can connect with --apiVersion 1 --apiStrict. Remove isMaster from any lists we have of API Version 1 features. Note that this only affects you if you're using apiStrict, and you're using a development version of a driver or shell and/or you're explicitly calling isMaster by name.

      Description of Linked Ticket

      This should involve overriding the apiVersions function for both the mongod and mongos implementations of the command and update our testing of the command with apiParameters.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              backlog-server-pm Backlog - Core Eng Program Management Team
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: