The following page which details system.profile content will need updating to reflect these changes:
The profile entry for update/delete should contain the entire raw update/delete in the command field, i.e. for updates:
and for deletes:
Remove the query, updateobj and collation fields, as they become redundant. Legacy updates/deletes should have the same format in the profile entry.
Extend profile_*.js tests to ensure that the arrayFilters are logged for update and findAndModify.
The log lines for individual updates/deletes and the currentOp should have the same command field. Their query, update, and collation fields should be removed.
The query/insert field should be renamed to command for all command's currentOp, log lines, and profile entries.