Uploaded image for project: 'Documentation'
  1. Documentation
  2. DOCS-15172

Make the Driver Compatibility Matrices more obvious in their support for connecting to "unsupported" versions

    XMLWordPrintable

Details

    • Improvement
    • Status: Resolved
    • Major - P3
    • Resolution: Done
    • None
    • None
    • drivers
    • None
    • 2
    • DET: Voldemort Q1S6, DET: LOLCODE Q2S1, DET: Fortran Q2S2, DET: Visual Basic Q2S4, DET: MUMPS Q2S5, DET: Racket Q2S6, DET: Ale Asylum Q3S1, DET: Elysian Q3S2
    • true

    Description

      Customers raise questions as a result of supportability for new versions of MongoDB from "older" drivers (such as https://www.mongodb.com/community/forums/t/mongodb-5-0-support-in-mongocxx/152102).

      This is due to the compatibility matrices not clearly identifying that older drivers "can still connect and interact with this version but newer features would not be supported". For example in https://docs.mongodb.com/drivers/cxx/#compatibility, the C++ driver doesn't show ANY support for MongoDB 5.0, which is confusing to customers.

      Attachments

        Issue Links

          Activity

            People

              mike.woofter@mongodb.com Mike Woofter
              alex.bevilacqua@mongodb.com Alex Bevilacqua
              Mike Woofter Mike Woofter
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                4 weeks, 1 day ago