Uploaded image for project: 'Documentation'
  1. Documentation
  2. DOCS-15396

[Server] Warn about incompatible drivers that use unsupported opcodes in 5.1+

    XMLWordPrintableJSON

Details

    • Task
    • Status: Backlog
    • Major - P3
    • Resolution: Unresolved
    • None
    • 6.0.0
    • manual, Server
    • None

    Description

      Outdated application drivers that use deprecated opcodes are no longer supported in 5.1+. Applications using outdated drivers will no longer see operations complete after upgrading the cluster to 5.1+.

      In the 6.0 docs, we should include a larger warning in the following locations informing users that drivers using legacy opcodes, that were deprecated in 3.6, are now unsupported and recommend to users to update their drivers to a version that uses supported opcodes.

      https://www.mongodb.com/docs/v6.0/release-notes/6.0-upgrade-standalone/#check-driver-compatibility
      https://www.mongodb.com/docs/v6.0/release-notes/6.0-compatibility/#legacy-opcodes-removed

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              edwin.zhou@mongodb.com Edwin Zhou
              Jess Mokrzecki Jess Mokrzecki
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                34 weeks, 4 days ago