Uploaded image for project: 'Documentation'
  1. Documentation
  2. DOCS-2908

That we run READ_UNCOMMITTED should be documented

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: v1.3.3
    • Component/s: manual
    • Labels:
      None
    • # Replies:
      1
    • Last comment by Customer:
      true
    • Actual Time:
      8

      Description

      We should update this page:

      http://docs.mongodb.org/manual/reference/write-concern/

      and this:

      http://docs.mongodb.org/manual/faq/fundamentals/#does-mongodb-support-acid-transactions

      to reflect the question posed here if the observed behavior is true:

      http://smalldatum.blogspot.com/2014/03/when-does-mongodb-make-transaction.html

      That is, if we consider the write fully committed only after it hits the journal, when j=true, then we should warn that another reader may see the write before it is fully committed. In the event of a failure and rollback, later readers may not see the write.

      This problem may also affect w=majority writes. In general, we want to guarantee the behavior that once a majority of members have seen the write, it is durable, even across the loss the primary. The problem is, if a majority of replica set nodes don't ack the write, and it's rolled back, someone on the primary may have already seen it.

      Essentially, we run READ_UNCOMMITTED. We should document this fact to avoid user confusion.

        Activity

        • Comments

          People

          • Votes:
            1 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since reply:
              2 years, 51 weeks, 5 days ago
              Date of 1st Reply: