Uploaded image for project: 'PHP Legacy Driver'
  1. PHP Legacy Driver
  2. PHP-1474

Declare no support for PHP 7

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: 1.6.11
    • Fix Version/s: 1.6.12
    • Component/s: pecl-mongo
    • Labels:
      None
    • # Replies:
      2
    • Last comment by Customer:
      true

      Description

      package.xml needs to be updated to declare no PHP 7 support.

      Currently the Windows buildbox always tries to do PHP 7 builds:

      php_mongo-1.6.11-7.0-nts-vc14-x64 failed
       
      php_mongo-1.6.11-7.0-ts-vc14-x64 failed
       
      php_mongo-1.6.11-7.0-nts-vc14-x86 failed
       
      php_mongo-1.6.11-7.0-ts-vc14-x86 failed
      

      I'm not sure if this `pecl install mongo` will also give better error message if package.xml mentions explicitly it won't support PHP 7.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since reply:
                  4 years, 9 weeks, 2 days ago
                  Date of 1st Reply: