Currently, we have hardcoded repetition of the test database name scattered throughout our testing code. This is pretty bad and annoying if we ever decide to use a different database name or if we want to do some functionality changes that involve doing something similar to generating a database name.
We should add a method to the testing base class introduced by
SWIFT-207 that returns the testing database name when called.
We should then change these instances of hardcoded repetition in the codebase to call this new method.