Uploaded image for project: 'Swift Driver'
  1. Swift Driver
  2. SWIFT-382

Mongo-Swift-Driver not supporting Swift 5.0 and Xcode 10.2

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Duplicate
    • Affects Version/s: 0.0.9
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      See github url in description for the environment

      Description

      Previously I've been dependent on MongoKitten, but they withdrawn support. They told they will not support since they are not obliged to support. They say it is free tool and no need to support. My project is delayed and money is lost. But I must not delay and loose money further.

       

      Now I'm depending on the mongo-swift-driver to interact with Mongo DB. But the developer is not responding to the issue https://github.com/mongodb/mongo-swift-driver/issues/224.

       

      Please help to solve it, since I need to have my application released for latest Swift 5 and Latest Xcode for all components. 

       

      I need to make decisions. If you guys not going to support future Swift versions then let me know so that I can make decisions.

       

      Are you guys committed to MongoDB and it's customers who are using different language to connect to your database? Swift is a major language!

       

      Looking forward your reply.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              matt.broadstone Matt Broadstone
              Reporter:
              kumar.muthaiah@yahoo.com Kumar Muthaiah
              Participants:
              Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: