Uploaded image for project: 'Swift Driver'
  1. Swift Driver
  2. SWIFT-618

Bump minimum Swift version to 5.1, and start testing against Swift 5.2

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 1.0.0-rc1
    • None
    • None

    Description

      We should:

      • Update README to state we support 5.1+
      • Update Evergreen to test against 5.1 and 5.2
      • Update the swift-tools-version in Package.swift
      • Update our swiftlint configuration to enforce the implicit return rule everywhere
      • Investigate all of the linked tickets and determine if any of them should be completed before we tag 1.0

      Attachments

        Issue Links

          Activity

            People

              kaitlin.mahar@mongodb.com Kaitlin Mahar
              patrick.freed@mongodb.com Patrick Freed
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: