The relevant spec is now the "MongoDB Handshake" spec, so replace "metadata" or "client metadata" in all variable and function names, test names, comments, filenames, etc. We should now refer to "handshake" and "handshake data".
Justification: someone familiar with the MongoDB Handshake Spec should be able to grep the driver for "handshake" and find the spec's implementation.
mongoc_metadata_append is the only public API I know of, maybe we should change that to mongoc_handshake_data_append before 1.4.0. The rest is internal code cleanup and can wait until 1.5 if needed.