Uploaded image for project: 'C Driver'
  1. C Driver
  2. CDRIVER-3437

drop python-git from debian-package-build task

    • Type: Icon: Task Task
    • Resolution: Fixed
    • Priority: Icon: Major - P3 Major - P3
    • 1.16.0
    • Affects Version/s: None
    • Component/s: Build
    • Labels:
      None

      The debian-package-build task is now failing with this error:

      E: Couldn't find these debs: python-git
      

      Since python-git upstream has dropped support for Python 2 the Debian maintainers have dropped the python-git binary package. The solution is to switch to the python3-git package. This should most likely work by changing the package that installed and changing the python invocations in .evergreen/debian_package_build.sh over to python3.

            Assignee:
            roberto.sanchez@mongodb.com Roberto Sanchez
            Reporter:
            roberto.sanchez@mongodb.com Roberto Sanchez
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Created:
              Updated:
              Resolved: