Uploaded image for project: 'C Driver'
  1. C Driver
  2. CDRIVER-3748

Document that commitQuorum is not supported on pre-4.4 servers

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 1.18.0, 1.18.0-alpha
    • docs
    • None

    Description

      CDRIVER-3627 explicitly decided not to add a wire version check for the commit quorum option, since libmongoc does not provide non-deprecated API to create indexes. Let's document that commitQuorum is not supported against pre-4.4 servers, and that libmongoc's generic command helpers do not validate this.

      Attachments

        Issue Links

          Activity

            People

              kevin.albertson@mongodb.com Kevin Albertson
              kevin.albertson@mongodb.com Kevin Albertson
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: