Uploaded image for project: 'Compass '
  1. Compass
  2. COMPASS-3757

Shows "Unknown" instead of "REPLICA SET" at the top left corner for PSA on Windows servers using Kerberos auth

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Declined
    • Affects Version/s: 1.18.0
    • Fix Version/s: No version
    • Component/s: Connectivity
    • Labels:
      None
    • # Replies:
      0
    • Last comment by Customer:
      true
    • Sprint:
      Iteration Jackal, Iteration Kangaroo
    • Case:

      Description

      • Customer is running a PSA replica set on Windows servers with Kerberos authenticationn enabled.
      • Connecting Compass to the primary with a replica set name yields the "Unknown" deployment type.
      • Connecting v1.19.0-beta.1 to the secondary with a replica set name yields "MongoError: DecryptMessage: The handle specified is invalid".
      • mongod.log entries from the PSA secondary show connections, client meta-data (ie. Compass Beta) and disconnection in less than a second. They do not show any message about authentication success or failure.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            brian.blevins Brian Blevins
            Participants:
            Last commenter:
            Brian Blevins
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since reply:
              1 year, 12 weeks, 1 day ago
              Date of 1st Reply: