Uploaded image for project: 'Compass '
  1. Compass
  2. COMPASS-6383

Investigate changes in NODE-4898: Make @aws-sdk/credential-providers an optional peerDependency

    • Type: Icon: Investigation Investigation
    • Resolution: Unresolved
    • Priority: Icon: Major - P3 Major - P3
    • None
    • Affects Version/s: None
    • Component/s: None
    • Labels:

      Use Case

      As a non aws user
      I want to not have aws-sdk installed by default
      So that I don't have extra modules installed

      As an aws user
      I want to have the aws-sdk version I install to be validated by npm
      So that I know I'm using a compatible version with the mongodb driver

      User Impact

      • Users need to install the aws-sdk as a dependency of their project if they are AWS auth users.

      Unknowns

      • questions that need to be answered to determine implementation

      Acceptance Criteria

      Implementation Requirements

      • Move aws-sdk to a peerDependency in package.json
      • Add optional: true to peerDependeciesMeta for aws-sdk
      • Import aws-sdk lazily inside aws auth logic

      Testing Requirements

      • Test dynamic import behavior

      Documentation Requirements

      • Add migration guide description

      Follow Up Requirements

      • additional tickets to file, required releases, etc

            Assignee:
            Unassigned Unassigned
            Reporter:
            dbeng-pm-bot PM Bot
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Created:
              Updated:

                Error rendering 'slack.nextup.jira:slack-integration-plus'. Please contact your Jira administrators.