Uploaded image for project: 'C# Driver'
  1. C# Driver
  2. CSHARP-2462

MongoDB.Driver.Core errors in .netStandard 2.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.7.2
    • Fix Version/s: None
    • Labels:
    • Environment:
      Windows 10 x64
      Unity 2018.3.0f2
      Visual Studio 2017

      Description

      Hi,

      The library MongoDB.Driver.Core

      Has errors when try to use in Unity 3D like:

      "Unable to resolve reference 'DnsClient'. Is the assembly missing or incompatible with the current platform?"

      And i open the source code in Visual Studio then change target framework to netStandard 2.0 but i have the same problem, too much dependencys missed, i try to solve it but i some cases can't because miss some functions an variables.

      Any suggestion?

       

      Regards.-

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: