Details

    • Type: New Feature New Feature
    • Status: Closed Closed
    • Priority: Major - P3 Major - P3
    • Resolution: Works as Designed
    • Affects Version/s: 1.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Backward Breaking:
      No
    • # Replies:
      2
    • Last comment by Customer:
      true

      Description

      Mongo supports the fsync command since 1.3 (http://www.mongodb.org/display/DOCS/fsync+Command). It would be good to have a way to do that from the C# driver.

        Activity

        Robert Stam
        added a comment -

        You can do this already:

        server.AdminDatabase.RunCommand("fsync");

        or if you want to provide the async flag:

        var fsync = new CommandDocument {

        { "fsync", 1 }

        ,

        { "async", 1 }

        };
        server.AdminDatabase.RunCommand(fsync);

        We chose not to add a helper method for this command because we feel it would be very rarely used. Does the above way of running an fsync seem adequate to you?

        Show
        Robert Stam
        added a comment - You can do this already: server.AdminDatabase.RunCommand("fsync"); or if you want to provide the async flag: var fsync = new CommandDocument { { "fsync", 1 } , { "async", 1 } }; server.AdminDatabase.RunCommand(fsync); We chose not to add a helper method for this command because we feel it would be very rarely used. Does the above way of running an fsync seem adequate to you?
        Flavien
        added a comment -

        Yes, this is fine, thank you. I just wasn't aware you could do that. You can close the work item.

        Show
        Flavien
        added a comment - Yes, this is fine, thank you. I just wasn't aware you could do that. You can close the work item.

          People

          • Assignee:
            Robert Stam
            Reporter:
            Flavien
            Participants:
            Last commenter:
            Craig Wilson
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since reply:
              2 years, 36 weeks, 4 days ago
              Date of 1st Reply: