C# Driver
  1. C# Driver
  2. CSHARP-397

How do i specify NoTimeout on a MongoCursor?

    Details

    • Type: Question Question
    • Status: Closed Closed
    • Priority: Trivial - P5 Trivial - P5
    • Resolution: Works as Designed
    • Affects Version/s: 1.3.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • # Replies:
      1
    • Last comment by Customer:
      false

      Description

      Is it just
      .SetOption("NoTimeout", BsonBoolean.True)

      thank you

        Activity

        • Comments
        Robert Stam
        added a comment -

        To set the NoCursorTimeout on the server side use:

        cursor.SetFlags(QueryFlags.NoCursorTimeout);
        

        This tells the server not to kill the cursor if it hasn't been used in 10 minutes.

        Show
        Robert Stam
        added a comment - To set the NoCursorTimeout on the server side use: cursor.SetFlags(QueryFlags.NoCursorTimeout); This tells the server not to kill the cursor if it hasn't been used in 10 minutes.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since reply:
              2 years, 9 weeks, 5 days ago
              Date of 1st Reply: