Uploaded image for project: 'C# Driver'
  1. C# Driver
  2. CSHARP-456

Support linq projections to only pull back referenced fields.

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Minor - P4
    • Resolution: Fixed
    • Affects Version/s: 1.4.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • # Replies:
      50
    • Last comment by Customer:
      true

      Description

      It should only pull back fields required for projection. In addition, it should support these forms
      1) simple projections: x.FirstName
      2) complex projections: x.FirstName + " " + x.LastName
      3) anonymous projections: new { Name = x.FirstName + " " + x.LastName
      4) class Projections: new PersonName(x.FirstName, x.LastName)

      { Age = x.BirthDate.ToAge() }

      );

        Issue Links

          Activity

          craiggwilson Craig Wilson added a comment -

          You'll want to track CSHARP-601.

          roysvork Pete Smith added a comment -

          Will do... let me know if there's anything I might be able to assist with.

          adro75 Adam Baldwin added a comment -

          Same here, this is killing our ability to use linq queries on large documents

          persi Olivier Ducros added a comment -

          Same problem here, should not be a minor bug, the problem is hidden and unexpected.

          craiggwilson Craig Wilson added a comment -

          This has been implemented in the 2.0 driver and, when LINQ is rewritten, CSHARP-601, it will be fully realized.


            People

            • Votes:
              53 Vote for this issue
              Watchers:
              40 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since reply:
                2 weeks ago
                Date of 1st Reply: