Uploaded image for project: 'Documentation'
  1. Documentation
  2. DOCS-12162

website Debian install by .deb instructions with Debian buster/testing

    XMLWordPrintable

    Details

      Description

      Description

      https://docs.mongodb.com/manual/tutorial/install-mongodb-on-debian/

      Hi, all. Sorry if this is a FAQ, but I am a newbie to MongoDB and am trying to install it on my Debian system according to the instructions above, and having problems.

      Perhaps it is that I my system is running  Debian buster/testing, not 9/Stretch?

      I go through steps 1 and 2.

      Then, on step three (running sudo apt-get update), I get a minor error or notice:

      # sudo apt-get update
      Hit:1 https://updates.signal.org/desktop/apt xenial InRelease
      Ign:2 http://repo.mongodb.org/apt/debian stretch/mongodb-org/4.0 InRelease 
      Hit:3 http://APT.spideroak.com/ubuntu-spideroak-hardy release InRelease 
      Hit:4 https://deb.nodesource.com/node_10.x buster InRelease 
      Hit:5 http://repo.mongodb.org/apt/debian stretch/mongodb-org/4.0 Release 
      Hit:6 https://riot.im/packages/debian artful InRelease 
      Hit:7 http://deb.debian.org/debian testing InRelease 
      Hit:8 https://apt.syncthing.net syncthing InRelease 
      Hit:10 http://deb.debian.org/debian buster InRelease
      Reading package lists... Done
      N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://repo.mongodb.org/apt/debian stretch/mongodb-org/4.0 InRelease' doesn't support architecture 'i386'
      #

      ..which I don't understand whether this will kill my installing mongodb or not. But I forge on:

      On step 4, under "Install the latest version of MongoDB" tab, when I try to install the main mongodb-org package, as per instructions, I hit a block:

       

      # apt-get install -y mongodb-org
      Reading package lists... Done
      Building dependency tree 
      Reading state information... Done
      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:
      The following packages have unmet dependencies:
       mongodb-org : Depends: mongodb-org-server but it is not going to be installed
      E: Unable to correct problems, you have held broken packages.
      # _
      

      When I try to install mongodb-org-server, similarly, I get an error about libcurl3:

       

      # apt-get install -y mongodb-org-server
      Reading package lists... Done
      Building dependency tree 
      Reading state information... Done
      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:
      The following packages have unmet dependencies:
       mongodb-org-server : Depends: libcurl3 (>= 7.16.2) but it is not installable
      E: Unable to correct problems, you have held broken packages.
      # _
      

      Likewise, when I try to install libcurl3..

      # apt-get install -y libcurl3
      Reading package lists... Done
      Building dependency tree 
      Reading state information... Done
      Package libcurl3 is not available, but is referred to by another package.
      This may mean that the package is missing, has been obsoleted, or
      is only available from another source
      However the following packages replace it:
       libcurl4:i386 libcurl4
      E: Package 'libcurl3' has no installation candidate
      root@sporkula:~#
      

       

      So when I try to install libcurl4..

       

      # apt-get install -y libcurl4
      Reading package lists... Done
      Building dependency tree 
      Reading state information... Done
      libcurl4 is already the newest version (7.61.0-1).
      0 upgraded, 0 newly installed, 0 to remove and 28 not upgraded.
      # _ 
      

      So I am at a loss. I've done what the instructions say, but perhaps it is that I am on debian/testing (buster)?  Or am I doing something else wrong? Thanks.

       

      Scope of changes

      Impact to Other Docs

      MVP (Work and Date)

      Resources (Scope or Design Docs, Invision, etc.)

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since reply:
                  24 weeks, 1 day ago
                  Date of 1st Reply: