-
Type: Bug
-
Resolution: Done
-
Priority: Major - P3
-
Affects Version/s: None
-
Component/s: None
-
None
In most documentation, you seem to refer to the attributes of a document as fields. In the Java driver documentation, you refer to them as keys (probably because you are using a map).
The following methods use two different terms:
containsKey(key)
removeField(key)
The rest of the methods refer to keys. This should be consistent with the rest of the documentation. If they are fields then set the param name as "name" or "fieldName". If you settle on fields then I would deprecate containsKey and add containsField(name).