Uploaded image for project: 'Java Driver'
  1. Java Driver
  2. JAVA-2734

Upgrade codenarc to version 1.1

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor - P4
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Internal
    • Labels:
      None

      Description

      Hello,

      I want to upgrade codeNarc to version 1.1 :

      https://github.com/CodeNarc/CodeNarc/blob/master/CHANGELOG.md

      I am particularly interested in bug fixes :

      #279: TrailingWhitespace: Fix to also support Windows line endings.
      

      Because I work on windows. And my PR failed on unix due to trailing whitespace.
      See conversation :
      https://github.com/mongodb/mongo-java-driver/pull/422
      https://github.com/mongodb/mongo-java-driver/pull/434

      But this release introduces new rules that make the build failed (see attachement).

      We can exclude these new rules except these 2 rules :

      BlockStartsWithBlankLine and BlockEndsWithBlankLine

      which are easy to apply.

      Or maybe we can excludes all new rules ?

      What do you think ?

      Farès

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            Farès Hassak Farès Hassak [X] (Inactive)
            Participants:
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: