Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major - P3 Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.7
    • Component/s: None
    • Labels:
      None
    • Environment:
      MongoDB 1.8.2 mac 64 bit
      Java driver 2.5.3
    • Operating System:
      ALL
    • # Replies:
      2
    • Last comment by Customer:
      false

      Description

      java.lang.NullPointerException
      at com.mongodb.gridfs.GridFSFile.validate(GridFSFile.java:63)
      at org.activiti.douglass.api.Cases.uploadCaseAttachment(Cases.java:84)

      Seems to be similar to a bug that was fixed before: JAVA-160

      Strange thing is that this bug is reproducable in maven and when running the same test in Eclipse it runs fine. Both test runs use the same mongodb.

      My code:

      81 GridFSInputFile gridFsFile = fileSystem.createFile(uploadStream, caze.getOid()+"/"+fileName);
      82 gridFsFile.setContentType(mimeType);
      83 gridFsFile.save();
      84 gridFsFile.validate();

      Driver code:

      54 public void validate() throws MongoException

      { 55 if ( _fs == null ) 56 throw new MongoException( "no _fs" ); 57 if ( _md5 == null ) 58 throw new MongoException( "no _md5 stored" ); 59 60 DBObject cmd = new BasicDBObject( "filemd5" , _id ); 61 cmd.put( "root" , _fs._bucketName ); 62 DBObject res = _fs._db.command( cmd ); 63 String m = res.get( "md5" ).toString(); 64 if ( m.equals( _md5 ) ) 65 return; 66 67 throw new MongoException( "md5 differ. mine [" + _md5 + "] theirs [" + m + "]" ); 68 }

        Activity

        Tom Baeyens
        added a comment -

        16:05:42,350 INF | activiti.cases.chunks ----------------------- [org.activiti.douglass.api.Activiti]
        16:05:42,350 INF | { "_id" :

        { "$oid" : "4de647361c8d6ce7c7cb7260"}

        , "files_id" :

        { "$oid" : "4de647361c8d6ce7c7cb725f"}

        , "n" : 0 , "data" : <Binary Data>} [org.activiti.douglass.api.Activiti]
        16:05:42,354 INF | activiti.cases.files ----------------------- [org.activiti.douglass.api.Activiti]
        16:05:42,355 INF | { "_id" :

        { "$oid" : "4de647361c8d6ce7c7cb725f"}

        , "chunkSize" : 262144 , "length" : 250 , "md5" : "3ba45e774d5b7a7d767cd0dc02da97df" , "filename" : "4de647361c8d6ce7c7cb725e/warning.txt" , "contentType" : "text conf def list log in = text/plain" , "uploadDate" :

        { "$date" : "2011-06-01T14:05:42Z"}

        , "aliases" : null } [org.activiti.douglass.api.Activiti]

        Show
        Tom Baeyens
        added a comment - 16:05:42,350 INF | activiti.cases.chunks ----------------------- [org.activiti.douglass.api.Activiti] 16:05:42,350 INF | { "_id" : { "$oid" : "4de647361c8d6ce7c7cb7260"} , "files_id" : { "$oid" : "4de647361c8d6ce7c7cb725f"} , "n" : 0 , "data" : <Binary Data>} [org.activiti.douglass.api.Activiti] 16:05:42,354 INF | activiti.cases.files ----------------------- [org.activiti.douglass.api.Activiti] 16:05:42,355 INF | { "_id" : { "$oid" : "4de647361c8d6ce7c7cb725f"} , "chunkSize" : 262144 , "length" : 250 , "md5" : "3ba45e774d5b7a7d767cd0dc02da97df" , "filename" : "4de647361c8d6ce7c7cb725e/warning.txt" , "contentType" : "text conf def list log in = text/plain" , "uploadDate" : { "$date" : "2011-06-01T14:05:42Z"} , "aliases" : null } [org.activiti.douglass.api.Activiti]
        auto
        added a comment -

        Author:

        {u'login': u'scotthernandez', u'name': u'Scott Hernandez', u'email': u'scotthernandez@gmail.com'}

        Message: JAVA-363: npe fix
        Branch: master
        https://github.com/mongodb/mongo-java-driver/commit/e177d745d6e0a76a7b03e09147035075a0e77494

        Show
        auto
        added a comment - Author: {u'login': u'scotthernandez', u'name': u'Scott Hernandez', u'email': u'scotthernandez@gmail.com'} Message: JAVA-363 : npe fix Branch: master https://github.com/mongodb/mongo-java-driver/commit/e177d745d6e0a76a7b03e09147035075a0e77494

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since reply:
              2 years, 26 weeks, 3 days ago
              Date of 1st Reply: