Java Driver
  1. Java Driver
  2. JAVA-466

Connection reset by peer: socket write error

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major - P3 Major - P3
    • Resolution: Duplicate
    • Affects Version/s: 2.7
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows7
    • Operating System:
      ALL
    • # Replies:
      4
    • Last comment by Customer:
      false

      Description

      After starting the server, when I access the application, it works fine. After some time letsay 15 mins when I try to do something it throws me a Connection reset by peer: socket write error. Looks like some issue with MongoDB Connection Pooling.

      I create a Singleton Instance of Mongo to connect to database.

      1. connection-error.txt
        12 kB
        jagadesh paladugula

        Issue Links

          Activity

          Scott Hernandez
          added a comment -

          What is the connection limit on the server? db.serverStatus()? Are there any server logs at the same time?

          Show
          Scott Hernandez
          added a comment - What is the connection limit on the server? db.serverStatus()? Are there any server logs at the same time?
          Jeff Yemin
          added a comment -

          Seems like this is a duplicate of JAVA-499.

          Show
          Jeff Yemin
          added a comment - Seems like this is a duplicate of JAVA-499 .
          Sergey Pichkurov
          added a comment -

          Any workaround to solve this issue?

          Show
          Sergey Pichkurov
          added a comment - Any workaround to solve this issue?
          Jeff Yemin
          added a comment -

          I wonder why the connections are getting reset. Can you try using "127.0.0.1" instead of "localhost" for the host name? Or try with 2.8.0-RC1, which fixes "localhost" handling?

          Show
          Jeff Yemin
          added a comment - I wonder why the connections are getting reset. Can you try using "127.0.0.1" instead of "localhost" for the host name? Or try with 2.8.0-RC1, which fixes "localhost" handling?

            People

            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since reply:
                1 year, 45 weeks, 3 days ago
                Date of 1st Reply: