Details

    • Type: Question Question
    • Status: Closed Closed
    • Priority: Major - P3 Major - P3
    • Resolution: Works as Designed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Performance
    • Labels:
      None
    • # Replies:
      24
    • Last comment by Customer:
      false

      Description

      https://groups.google.com/d/topic/mongodb-user/JvlCDGQI65g/discussion

      In a simple test Java application first query for 3000 elements occurs within 350-400 ms, the second and subsequent occur faster. In the same PHP application query the results are 10-15ms. This is a very serious limitation for web applications.

      I'm not sure that this is normal behavior for java driver. What could be wrong?

      1. App.java
        5 kB
        Ilya Skorik
      2. LoginForm.java
        1 kB
        Ilya Skorik
      3. LoginForm.java
        1 kB
        Ilya Skorik
      4. LoginForm.java
        2 kB
        Ilya Skorik
      5. matrix-app.log
        47 kB
        Ilya Skorik
      6. matrix-app.log
        48 kB
        Ilya Skorik
      7. MongoConfig.java
        1 kB
        Ilya Skorik
      8. mongotest.php
        0.7 kB
        Ilya Skorik

        Activity

        Ilya Skorik
        added a comment -

        https://jira.springsource.org/browse/DATAMONGO-520

        Spring-data-mongodb issue created, I will try Morphia

        Show
        Ilya Skorik
        added a comment - https://jira.springsource.org/browse/DATAMONGO-520 Spring-data-mongodb issue created, I will try Morphia
        Jeff Yemin
        added a comment -

        OK, sounds good. Good luck.

        Show
        Jeff Yemin
        added a comment - OK, sounds good. Good luck.
        Scott Hernandez
        added a comment -

        Ilya, please make sure connectionsForHost is set to the max number of threads which may be active. that error about semaphores says it is too low.

        Show
        Scott Hernandez
        added a comment - Ilya, please make sure connectionsForHost is set to the max number of threads which may be active. that error about semaphores says it is too low.
        Ilya Skorik
        added a comment -

        Thank you all for your participation, the problem with semaphores is probably due to limitations of the client OS. Current level of performance I have more than satisfied. Thank you again!

        Show
        Ilya Skorik
        added a comment - Thank you all for your participation, the problem with semaphores is probably due to limitations of the client OS. Current level of performance I have more than satisfied. Thank you again!
        Jeff Yemin
        added a comment -

        It's not a client OS issue. You just need to increase connectionsPerHost in MongoOptions to ensure there are enough connections to adequately account for the number of threads in the app server that are concurrently using Mongo.

        Show
        Jeff Yemin
        added a comment - It's not a client OS issue. You just need to increase connectionsPerHost in MongoOptions to ensure there are enough connections to adequately account for the number of threads in the app server that are concurrently using Mongo.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since reply:
              1 year, 33 weeks, 3 days ago
              Date of 1st Reply: