Uploaded image for project: 'Mongoid'
  1. Mongoid
  2. MONGOID-1544

Remove Support for 1.8.x

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 3.0.0
    • Component/s: None

      Description

      • 1.9.2 + has been out and stable for almost a year and a half now.
      • 1.9.3 provides GC configuration that REE does.
      • JRuby and Rubinius allow 1.9.x syntax for our needs.
      • New hash syntax, lambda syntax can clean up a lot of Mongoid code.
      • Rails master does not support 1.8
      • Moped relies on 1.9 specific IO ops for speed.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: