Uploaded image for project: 'MongoDB Shell'
  1. MongoDB Shell
  2. MONGOSH-1283

Enterprise PowerPC and Z RPMs are missing from repos, causing server RPM to fail to install

    • Type: Icon: Bug Bug
    • Resolution: Fixed
    • Priority: Icon: Major - P3 Major - P3
    • 1.6.0
    • Affects Version/s: 1.5.4
    • Component/s: Packaging
    • Labels:
      None
    • 2
    • Not Needed
    • Iteration Herring

      Problem Statement/Rationale

      The 5.0/6.0 enterprise server RHEL8+ RPMs declare a dependency on mongodb-mongosh , which exists for x86_64 and arm64 architectures, but I don’t see it available for Z or Power. When I attempt to install the server packages for those arches, dnf complains that it can’t resolve mongodb-mongosh . I do see e.g. mongodb-enterprise-shell-5.0.9-1.el8.ppc64le.rpm , but not mongodb-mongosh. I believe the fix here is to just start publishing 5.0 and 6.0 PowerPC/Z RPMs for RHEL 8 (and soon 9).

      Related Slack conversation: https://mongodb.slack.com/archives/CUHC9R8J0/p1659467314722449

            Assignee:
            anna.henningsen@mongodb.com Anna Henningsen
            Reporter:
            dylan.richardson@mongodb.com Dylan Richardson
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Created:
              Updated:
              Resolved:

                Error rendering 'slack.nextup.jira:slack-integration-plus'. Please contact your Jira administrators.