Uploaded image for project: 'MongoDB Shell'
  1. MongoDB Shell
  2. MONGOSH-1553

Display warnings when running mongosh in unsupported environments

    • Type: Icon: Task Task
    • Resolution: Done
    • Priority: Icon: Major - P3 Major - P3
    • 2.0.0
    • Affects Version/s: None
    • Component/s: None
    • Labels:
      None
    • Needed
    • Hide

      Mongosh will start showing deprecation warnings when run:
      1) On platforms where GLIBC version is below 2.28
      2) On Node.js < 20.0.0
      3) With OpenSSL < 3.0.0

      We would like to point this out in our documentation as recommended requirements for running 2.0.0

      Show
      Mongosh will start showing deprecation warnings when run: 1) On platforms where GLIBC version is below 2.28 2) On Node.js < 20.0.0 3) With OpenSSL < 3.0.0 We would like to point this out in our documentation as recommended requirements for running 2.0.0
    • Iteration Hagryphus

      We add a deprecation notice/warning to mongosh when running mongosh on platforms that do not meet the official requirements for running Node.js 20, using the process.report feature to look up the current glibc version, or when running it under a Node.js version lower than Node.js 20.

      (The glibc minimum for Node.js 20 is 2.28, see https://github.com/nodejs/node/blob/v20.x/BUILDING.md#platform-list, and this warning should not be shown when running mongosh in --quiet mode.)

            Assignee:
            himanshu.singh@mongodb.com Himanshu Singh
            Reporter:
            anna.henningsen@mongodb.com Anna Henningsen
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Created:
              Updated:
              Resolved:

                Error rendering 'slack.nextup.jira:slack-integration-plus'. Please contact your Jira administrators.