Uploaded image for project: 'MongoDB Shell'
  1. MongoDB Shell
  2. MONGOSH-826

MongoError: Optional module `snappy` not found. Please install it to enable snappy compression

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Won't Do
    • Affects Version/s: None
    • Fix Version/s: No version
    • Component/s: CLI Module
    • Labels:
      None
    • Documentation Changes:
      Not Needed

      Description

      Problem Description

      Steps to Reproduce

      MongoDB Enterprise atlas-q8j1bk-shard-0:PRIMARY> db._adminCommand({getCmdLineOpts: 1}).parsed.net.compression
      >>> { "compressors" : "snappy,zstd,zlib" }

       

      mongosh "mongodb+srv://zstd.g3mcy.mongodb.net/?compressors=snappy" --username main_user --password bryanzelle
      >>> MongoError: Optional module `snappy` not found. Please install it to enable snappy compression

      Expected Results

      Expect to connect to the database like what happens if you pass it a value of zlib. 

      mongosh "mongodb+srv://zstd.g3mcy.mongodb.net/?compressors=zlib" --username main_user --password bryanzelle

      >>> 
      Current Mongosh Log ID: 60c2be5ca3e868168fe5f247
      Connecting to: mongodb+srv://zstd.g3mcy.mongodb.net/?compressors=zlib
      Using MongoDB: 4.4.6
      Using Mongosh Beta: 0.14.0

      Enterprise atlas-q8j1bk-shard-0 [primary]>

      Actual Results

      Additional Notes

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              bryan.zelle Bryan Zelle
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: