Uploaded image for project: 'Motor'
  1. Motor
  2. MOTOR-378

Motor 2.1 should require 4.0>PyMongo>=3.9

    • Type: Icon: Task Task
    • Resolution: Fixed
    • Priority: Icon: Major - P3 Major - P3
    • 2.1
    • Affects Version/s: None
    • Component/s: None
    • Labels:

      It is unclear why any given MOTOR release supports a range of PyMongo versions as opposed to a single PyMongo version (the latest). The PHP driver, for instance, always bumps its dependency on libmongoc when cutting a release corresponding to a new server version.

      It seems logical that a 4.2-compatible release of Motor would require the 4.2-compatible PyMongo release at a minimum. However, with the way things are currently setup, the 4.2-compatible release of Motor would install with any 4>PyMongo>=3.6. This will result in unexpected errors if the user attempts to use server features that aren't supported by the version of PyMongo installed. More confusingly still, such a scheme decouples server-compatbility from the Motor-version in use, as users need to inspect the PyMongo version installed in order to infer the latest supported server version.

            prashant.mital Prashant Mital (Inactive)
            prashant.mital Prashant Mital (Inactive)
            0 Vote for this issue
            2 Start watching this issue