Uploaded image for project: 'Node Driver'
  1. Node Driver
  2. NODE-1307

Cannot Connect to Single Node Replica Set on Windows when RS Name Provided

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical - P2
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.2.34, 3.0.2
    • Fix Version/s: 3.0.6
    • Component/s: core
    • Labels:
      None
    • Case:

      Description

      The driver cannot connect to a single node replica set when the replica set name is provided on Windows.

      I have provided 3 screen shots, 1 Electron console on Windows (failing), 1 Node console on Windows (failing), 1 Electron console on OSX (passing, although in Compass the SDAM events are not determining the server type properly).

      Steps to reproduce:

      • Spin up a replica set with only one node in it. For my example I've turned off authentication and named the replica set "single". Ensure the single Node is a primary.
      • Connect to the single Node from a Windows machine via MongoClient#connect with the replica set name and read preference in the connection string. I'm replicating on Windows 10 both from the Node REPL and the Electron console.
      • Driver will yield a "MongoNetworkError" after a bit of a hang.
      • Note that if the replica set name is not provided in the connection string, the connection will succeed.

        Attachments

        1. compass-server-type-unknown.png
          compass-server-type-unknown.png
          235 kB
        2. osx-no-error.png
          osx-no-error.png
          584 kB
        3. windows-error-electron.png
          windows-error-electron.png
          177 kB
        4. windows-error-node-repl.png
          windows-error-node-repl.png
          560 kB

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: