Rename `getServer` to `selectServer` in old topology types

XMLWordPrintableJSON

    • Type: Improvement
    • Resolution: Fixed
    • Priority: Major - P3
    • 3.1.3
    • Affects Version/s: None
    • Component/s: None
    • None
    • None
    • None
    • None
    • None
    • None
    • None

      This is changes does a few things for us:

      • It aligns the APIs of the old and new topology types, and makes the new topology type a drop-in replacement
      • It cleans up existing code that depends on this method being synchronous to use callbacks, which will be important once the underlaying topology is actually doing proper server selection

              Assignee:
              Matt Broadstone
              Reporter:
              Matt Broadstone
              None
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Created:
                Updated:
                Resolved: