Uploaded image for project: 'PHP Driver: Extension'
  1. PHP Driver: Extension
  2. PHPC-1104

pecl package misses zlib sources

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: 1.4.0-RC1
    • Fix Version/s: 1.4.0-RC2, 1.4.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      Cleanly installed Ubuntu 17.10

      Description

      Installing mongodb-1.4.0RC1 with pecl install -f mongodb-1.4.0RC1 on a cleanly installed Ubuntu 17.10 fails because: 1. Ubuntu doesn't by default install libz-dev; 2. we didn't bundle the zlib sources in our installation package, although we tried to use it:

      config.status: creating /tmp/pear/temp/mongodb/src/libmongoc/src/mongoc/mongoc-config.h
      config.status: creating /tmp/pear/temp/mongodb/src/libmongoc/src/mongoc/mongoc-version.h
      config.status: error: cannot find input file: `/tmp/pear/temp/mongodb/src/libmongoc/src/zlib-1.2.11/zconf.h.in'
      ERROR: `/tmp/pear/temp/mongodb/configure --with-php-config=/usr/bin/php-config' failed
      

        Attachments

          Activity

            People

            Assignee:
            derick Derick Rethans
            Reporter:
            derick Derick Rethans
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: