Uploaded image for project: 'PHP Driver: Extension'
  1. PHP Driver: Extension
  2. PHPC-480

Don't require OpenSSL for MongoDB3.0+ authentication

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker - P1
    • Resolution: Won't Fix
    • Affects Version/s: 1.0.0
    • Fix Version/s: None
    • Labels:
      None

      Description

      Requiring building against, and using, OpenSSL was deemed not kosher and the PHP and HHVM drivers would have to vendor in required code to make SCAM-SHA1 work when HHVM/PHP was installed without ext/openssl and OpenSSL otherwise not available.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: