Uploaded image for project: 'Python Driver'
  1. Python Driver
  2. PYTHON-1411

mongo-python-driver builds are not reproducible

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Trivial - P5
    • Resolution: Fixed
    • Affects Version/s: 3.5.1
    • Fix Version/s: 3.6
    • Component/s: Build
    • Labels:
      None
    • Environment:
      Debian

      Description

      The mongo-python-driver is not reproducible. As part of reproducible-builds effort, the package should be identical each and every time the package is built and it should not depend on the current build environment. A copyright message is displayed in the python driver files which depends on the current system date. This issue has been fixed to remove the dependency. Please visit the below URL for more information about reproducible-builds.

      https://wiki.debian.org/ReproducibleBuilds/About

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: