Uploaded image for project: 'Python Driver'
  1. Python Driver
  2. PYTHON-1951

Cap dnspython dependency at 1.16 on Python 2

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 3.9
    • None
    • None

    Description

      The stable version of dnspython is 1.16.0, released on December 8, 2018.

      Python 2.x support ends with the release of 1.16.0, unless there are critical bugs in 1.16.0. Future versions of dnspython will only support Python 3.

      http://www.dnspython.org/

      I think we might need to cap our dnspython req to <=1.16 on Python 2 to avoid installing incompatible versions.

      Attachments

        Activity

          People

            bernie@mongodb.com Bernie Hackett
            shane.harvey@mongodb.com Shane Harvey
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: