Uploaded image for project: 'Python Driver'
  1. Python Driver
  2. PYTHON-1974

Drop Python 3.4 support

    XMLWordPrintable

    Details

    • Type: Epic
    • Status: Open
    • Priority: Major - P3
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 4.0
    • Component/s: None
    • Labels:
      None
    • Epic Name:
      PyMongo drop support for Python 3.4

      Description

      Since Python 3.4 reached its end-of-life in March 2019, we should consider dropping support for it in PyMongo 4.0.

      Note that our ability to do this could be limited by the need to support Operating Systems that ship with Python 3.4 as one of the pre-installed Python runtimes.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              prashant.mital Prashant Mital
              Participants:
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated: