Uploaded image for project: 'Python Driver'
  1. Python Driver
  2. PYTHON-2117

python_full_version comparison fails due to poor environment marker support in older setuptools versions

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Minor - P4
    • Resolution: Fixed
    • None
    • 3.11
    • Build
    • None

    Description

      This line (one of three in setup.py) causes a python version of 2.7.12 to be "less than" 2.7.9:

      + extras_require['tls'].append("wincertstore>=0.2 ; python_full_version < '2.7.9'")

      which then can cause this error:

      /usr/lib64/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'python_requires'
        warnings.warn(msg)
      error in pymongo setup command: 'extras_require' must be a dictionary whose values are strings or lists of strings containing valid project/version requirement specifiers.
      

      Attachments

        Issue Links

          Activity

            People

              bernie@mongodb.com Bernie Hackett
              milkie@mongodb.com Eric Milkie
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: