Uploaded image for project: 'Python Driver'
  1. Python Driver
  2. PYTHON-2811

Migrate versioned api testing from ubuntu1804 to amazon1-2018

    XMLWordPrintableJSON

Details

    • Task
    • Status: Closed
    • Unknown
    • Resolution: Fixed
    • None
    • 3.12
    • None
    • None

    Description

      Similar to PYTHON-2774, Python 2.7 no longer is installed on ubuntu1804. We need to migrate to amazon1-2018:

       [2021/07/13 00:23:30.196] Running command 'shell.exec' in "run tests" (step 2.2 of 2)
       [2021/07/13 00:23:30.224] /data/mci/ef6d80b3680e6122bee74d98b28ad8d9/src/.evergreen/run-tests.sh: line 198: /opt/python/2.7/bin/python: No such file or directory
       [2021/07/13 00:23:30.225] Command failed: command encountered problem: error waiting on process '2de658fe-8867-4b0d-93db-7254facddd3b': exit status 127
      

      https://evergreen.mongodb.com/task/mongo_python_driver_3.12_versioned_api_tests__platform~ubuntu_18.04_auth~auth_python_version~2.7_versionedApi~acceptApiVersion2_test_latest_standalone_da975723f60b52fe6598d2f6118dc3b37d2779a2_21_07_13_00_16_41

      Attachments

        Activity

          People

            shane.harvey@mongodb.com Shane Harvey
            shane.harvey@mongodb.com Shane Harvey
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: