Uploaded image for project: 'Python Driver'
  1. Python Driver
  2. PYTHON-2971

PossiblePrimary must not be checked for wire version compatibility of MaxStalenessSeconds

    XMLWordPrintableJSON

Details

    • Spec Change
    • Status: Closed
    • Minor - P4
    • Resolution: Fixed
    • None
    • 4.0
    • Spec Comp
    • None
    • Hide

      DRIVERS-1912:
      The Max Staleness specification requires drivers check wire version for support of maxStalenessSeconds:

      Clients are required to throw an error if maxStalenessSeconds is set, and any server in the topology has maxWireVersion less than 5.

      Servers of type PossiblePrimary must not be considered in this check, since they have no known maxWireVersion.

      Show
      DRIVERS-1912: The Max Staleness specification requires drivers check wire version for support of maxStalenessSeconds: Clients are required to throw an error if maxStalenessSeconds is set, and any server in the topology has maxWireVersion less than 5. Servers of type PossiblePrimary must not be considered in this check, since they have no known maxWireVersion.

    Description

      This ticket was split from DRIVERS-1912, please see that ticket for a detailed description.

      Attachments

        Issue Links

          Activity

            People

              julius.park@mongodb.com Julius Park
              dbeng-pm-bot PM Bot
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: