-
Type: Task
-
Resolution: Fixed
-
Priority: Unknown
-
Affects Version/s: None
-
Component/s: None
-
None
After discussing DRIVERS-2664 and rereading the runCursorCommand spec, I believe we can remove some of the unneeded arguments from the db.cursor_command method added in PYTHON-3588. For example, let's remove:
- "check": we always have to check the command response because we can't create the cursor otherwise so this option isn't functional.
- "allowable_errors": we can't ignore errors for the same reason
- "batch_size": users can already set the getMore batchSize via the CommandCursor.batch_size() method.
We should also:
- rename "max_time_ms" to "max_await_time_ms" for consistency with other apis.
- update the "comment" doc string should clarify that's only used for getMores.
- related to
-
PYTHON-3588 Expose an API to create a cursor from a command response
- Closed