Uploaded image for project: 'Python Driver'
  1. Python Driver
  2. PYTHON-665

PyMongo 3 - Drop support for Python 2.4, 2.5, and 3.1

    XMLWordPrintableJSON

Details

    • Task
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 3.0
    • None
    • None

    Description

      Python 2.4, 2.5, and 3.1 are ancient history. Supporting them means not being able to use any reasonably modern python features (e.g. context managers...) and makes single source py2/3 support very difficult. Most of the rest of the python universe has dropped support for these old versions. We're doing it as well.

      If you need to continue to use any of these python versions with MongoDB the 2.x branch of PyMongo will continue to be minimally maintained for some time.

      Attachments

        Activity

          People

            bernie@mongodb.com Bernie Hackett
            bernie@mongodb.com Bernie Hackett
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: