Uploaded image for project: 'Python Driver'
  1. Python Driver
  2. PYTHON-722

Manage sockets with a context manager

    • Type: Icon: Improvement Improvement
    • Resolution: Done
    • Priority: Icon: Major - P3 Major - P3
    • 3.0
    • Affects Version/s: None
    • Component/s: None
    • Labels:
      None
    • Fully Compatible

      Since PyMongo requires Python 2.6+, we can use Python with-statements context managers to avoid socket leaks in the face of exceptions.

            Assignee:
            jesse@mongodb.com A. Jesse Jiryu Davis
            Reporter:
            jesse@mongodb.com A. Jesse Jiryu Davis
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Created:
              Updated:
              Resolved: