Uploaded image for project: 'Python Driver'
  1. Python Driver
  2. PYTHON-764

SCRAM-SHA-1 upgrade / downgrade support

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8, 3.0
    • Component/s: None
    • Labels:
      None
    • Sprint:
      Python Sprint 9

      Description

      When authentication is used, but no explicit authMechanism is provided:

      • Use SCRAM-SHA-1 when connected to MongoDB >= 2.8
      • Use MONGODB-CR when connected to MongoDB < 2.8

      Use maxWireVersion to decide.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              jesse A. Jesse Jiryu Davis
              Reporter:
              behackett Bernie Hackett
              Participants:
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: