Uploaded image for project: 'Python Driver'
  1. Python Driver
  2. PYTHON-893

Wrong wrapping function called for CommandCursor

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • 2.7.2, 2.8, 3.0
    • 3.0.1, 2.8.1
    • None
    • None

    Description

      CommandCursor wraps object with function _fix_incoming (https://github.com/mongodb/mongo-python-driver/blob/master/pymongo/command_cursor.py#L170), but instead object shoud be wrapped with _fix_outgoing like in Cursor (https://github.com/mongodb/mongo-python-driver/blob/master/pymongo/cursor.py#L971)

      And also I suggest to rename functions to something like "*_to_database" and "*_from_database", because current function names (*_outgoing and *_incoming) are very confusing.

      Attachments

        Activity

          People

            bernie@mongodb.com Bernie Hackett
            Last G Last G [X]
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: