Uploaded image for project: 'Realm JavaScript SDK'
  1. Realm JavaScript SDK
  2. RJS-2450

Rename `type` in `OpenBehavior`

    • Type: Icon: Task Task
    • Resolution: Unresolved
    • Priority: Icon: Minor - P4 Minor - P4
    • None
    • Affects Version/s: None
    • Component/s: Node.js, React Native
    • Labels:
      None

      I think the naming could be improved for OpenRealmBehaviorConfiguration. Currently it is:

      {
        type: OpenBehaviorType;
        timeout?: number;
        timeoutBehavior?: OpenBehaviorType;
      }
      

      I think it should be:

      {
        behavior: OpenBehavior;
        timeout?: number;
        timeoutBehavior?: OpenBehavior;
      }
      

      In my opinion, the "Type" word is too generic and its usage should be avoided unless it's really unavoidable.

            Assignee:
            Unassigned Unassigned
            Reporter:
            andrew.meyer@mongodb.com Andrew Meyer
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Created:
              Updated: