Uploaded image for project: 'Realm Kotlin'
  1. Realm Kotlin
  2. RKOTLIN-163

Evaluate if `RealmObject.version` is the best way to expose it

    • Type: Icon: Improvement Improvement
    • Resolution: Fixed
    • Priority: Icon: Major - P3 Major - P3
    • None
    • Affects Version/s: None
    • Component/s: None
    • None

      Right now RealmObject.version is an extension method, but the plan was to move it to an interface method. This has a number of complications though:

      • version is a very generic name and there is a high chance it conflict with user code
      • If we change it to e.g. realmVersion, should we also change Realm.version, RealmResults.version and RealmList.version ?
      • Exposing it as RealmObject.realm.version also seems problematic as we don't have multiple Realm instances.

      This PR is about evaluating what the best way of doing it is? variable or function? And what the final name should be.

            Assignee:
            Unassigned Unassigned
            Reporter:
            unitosyncbot Unito Sync Bot
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Created:
              Updated:
              Resolved: