Uploaded image for project: 'Ruby Driver'
  1. Ruby Driver
  2. RUBY-1047

How to perform new relic instrumentation/monitoring with >= ruby 2.0 driver for mongo

    XMLWordPrintable

    Details

    • Type: Question
    • Status: Closed
    • Priority: Trivial - P5
    • Resolution: Done
    • Affects Version/s: 2.1.0, 2.1.1
    • Fix Version/s: 12_01_17
    • Component/s: None
    • Labels:
    • Environment:
      My system is Mac book pro on OSX version 10.10.5

      Description

      https://docs.newrelic.com/docs/agents/ruby-agent/frameworks/mongo-instrumentation#supported_gems

      The above link says "The Ruby agent currently supports the mongo gem versions 1.8 and 1.9. mongo is receiving major updates for its 2.0 version, and the Ruby agent plans to support that version as it becomes available."
      I have mongodb version(3.0), so only mongo ruby driver 2.0 version is compatible according to the below link.
      http://docs.mongodb.org/ecosystem/drivers/driver-compatibility-reference/#ruby-driver-compatibility

      • newrelic_rpm (3.9.9.275) This is the current new relic version

      My requirement is i need to enable new relic monitoring possible with mongodb version >= 3.0 and ruby driver version >= 2.0 and newrelic_rpm version >= 3.9.9.

      Please list out the steps for above task. Please give your answers asap.

        Attachments

          Activity

            People

            Assignee:
            durran.jordan Durran Jordan
            Reporter:
            rajkumar.cs545@gmail.com M Kumar Raja
            Participants:
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: