Uploaded image for project: 'Ruby Driver'
  1. Ruby Driver
  2. RUBY-2059

Dependency on bson 4.6 forces driver 2.10.3 to require Ruby 2.3+/JRuby 9.2+

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: 2.10.3
    • Fix Version/s: 2.11.3, 2.10.4, 2.12.0.rc0
    • Component/s: None
    • Labels:
      None
    • Backwards Compatibility:
      Fully Compatible

      Description

      The 2.10.3 driver is advertised as still supporting JRuby 1.7 (Ruby 1.9+). However, the 10.3 gemspec requires bson version 4.6, which itself requires Ruby 2.3+/JRuby 9.2+, and therefore it transitively forces 10.3 to become required on Ruby 2.3+/JRuby 9.2+ as well.

      The prior version of bson, 4.5, appears to still support older version of Ruby/JRuby.

      I see that the upgrading from bson 4.4.2 to bson 4.6 was intended to fix https://jira.mongodb.org/browse/RUBY-1980 in https://github.com/mongodb/mongo-ruby-driver/commit/ffc8ca848f878176786fdf1fe1b478c151ef52d2

      Reading the changes from bson 4.5 to bson 4.6: https://github.com/mongodb/bson-ruby/releases/tag/v4.6.0 It is not clear to me if the bson 4.6 changes are needed to support the fix on https://jira.mongodb.org/browse/RUBY-1980. If not, I recommend downgrade to bson 4.5 to restore support for older Ruby.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              oleg.pudeyev Oleg Pudeyev
              Reporter:
              ckpeter Peter Chan
              Participants:
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: